<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <!-- This site is optimized with the Yoast SEO plugin v17.8 - https://yoast.com/wordpress/plugins/seo/ --><title>Category Theory: Lecture Notes and Online Books - Logic Matters</title><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin/><link rel="preconnect" href="https://fonts.googleapis.com"/><style type="text/css">@font-face {
 font-family: 'Merriweather';
 font-style: normal;
 font-weight: 300;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v27/u-4n0qyriQwlOrhSvowK_l521wRZWMf_.ttf) format('truetype');
}
@font-face {
 font-family: 'Merriweather';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/merriweather/v27/u-440qyriQwlOrhSvowK_l5-fCZJ.ttf) format('truetype');
}
@font-face {
 font-family: 'PT Sans';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/ptsans/v12/jizaRExUiTo99u79D0KEwA.ttf) format('truetype');
}
@font-face {
 font-family: 'PT Serif';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/ptserif/v12/EJRVQgYoZZY2vCFuvAFWzro.ttf) format('truetype');
} </style><link rel="stylesheet" id="siteground-optimizer-combined-css-e1c20a1ff7e417eeb7fde431a9d058a7" href="https://www.logicmatters.net/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-e1c20a1ff7e417eeb7fde431a9d058a7.css" media="all" /><link rel="preload" href="https://www.logicmatters.net/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-e1c20a1ff7e417eeb7fde431a9d058a7.css" as="style"><link rel="canonical" href="https://www.logicmatters.net/categories/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Category Theory: Lecture Notes and Online Books - Logic Matters" /><meta property="og:description" content="The links below are to various freely (and legitimately!) available online mathematical resources for those interested in category theory at an elementary/intermediate level. There is supplementary page, introductory readings for philosophers, for reading suggestions for those looking for the most accessible routes into category theory and/or links to philosophical discussions. A gentle introduction? My Category &hellip; Category Theory: Lecture Notes and Online Books Read More &raquo;" /><meta property="og:url" content="https://www.logicmatters.net/categories/" /><meta property="og:site_name" content="Logic Matters" /><meta property="article:modified_time" content="2021-08-01T10:26:17+00:00" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@PeterSmith" /><meta name="twitter:label1" content="Est. reading time" /><meta name="twitter:data1" content="7 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.logicmatters.net/#website","url":"https://www.logicmatters.net/","name":"Logic Matters","description":"Logic, music, and other enthusiasms","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.logicmatters.net/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.logicmatters.net/categories/#webpage","url":"https://www.logicmatters.net/categories/","name":"Category Theory: Lecture Notes and Online Books - Logic Matters","isPartOf":{"@id":"https://www.logicmatters.net/#website"},"datePublished":"2015-01-02T17:51:32+00:00","dateModified":"2021-08-01T10:26:17+00:00","breadcrumb":{"@id":"https://www.logicmatters.net/categories/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.logicmatters.net/categories/"]}]},{"@type":"BreadcrumbList","@id":"https://www.logicmatters.net/categories/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.logicmatters.net/"},{"@type":"ListItem","position":2,"name":"Category Theory: Lecture Notes and Online Books"}]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Logic Matters &raquo; Feed" href="https://www.logicmatters.net/feed/" /><link rel="alternate" type="application/rss+xml" title="Logic Matters &raquo; Comments Feed" href="https://www.logicmatters.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Logic Matters &raquo; Category Theory: Lecture Notes and Online Books Comments Feed" href="https://www.logicmatters.net/categories/feed/" /> <style> img.wp-smiley,
img.emoji {
 display: inline !important;
 border: none !important;
 box-shadow: none !important;
 height: 1em !important;
 width: 1em !important;
 margin: 0 .07em !important;
 vertical-align: -0.1em !important;
 background: none !important;
 padding: 0 !important;
} </style> <style id='astra-theme-css-inline-css'>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</style> <style id='global-styles-inline-css'>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</style> <style id='astra-addon-css-inline-css'>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</style> <!--[if IE]> <script defer src='https://www.logicmatters.net/wp-content/themes/astra/assets/js/minified/flexibility.min.js' id='astra-flexibility-js'></script> <script defer id='astra-flexibility-js-after'> flexibility(document.documentElement); </script> <![endif]--> <script src='https://www.logicmatters.net/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script><link rel="https://api.w.org/" href="https://www.logicmatters.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.logicmatters.net/wp-json/wp/v2/pages/6337" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.logicmatters.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.logicmatters.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.8.2" /><link rel='shortlink' href='https://www.logicmatters.net/?p=6337' /><link rel="alternate" type="application/json+oembed" href="https://www.logicmatters.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.logicmatters.net%2Fcategories%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.logicmatters.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.logicmatters.net%2Fcategories%2F&#038;format=xml" /> <!-- Custom Twitter Feeds CSS --> <style type="text/css"> .ctf-item:first-of-type, .ctf-item:first-of-type .ctf-author-box-link a {
 margin-top: 0 !Important;
 padding-top: 0 !important;
}  #ctf .ctf-item{
 padding: -6px 0px;
 margin: -12px 0px;
 border-top: 1px solid #ddd;
 border-top: 1px solid rgba(0,0,0,0.1);
 overflow: hidden;
} </style><link rel="pingback" href="https://www.logicmatters.net/xmlrpc.php"> <style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style id="sccss">/* Enter Your Custom CSS Here */  .ast-comment {
 padding: 0;
 font-family: 'PT Serif';
 font-size: 14px;
}  .ast-comment-meta {
 padding: 0 1.2em 0;
}  .ast-separate-container .comments-title {
 background-color: #fff;
 padding: 1.2em 1.5em 0;
 font-family: 'PT Serif';
 font-size: 24px;
 font-weight: normal;
 color: black;
}  .ast-comment-content .comment p {
 margin-bottom: 1.2em;
}  .ast-comment-info {
 font-family: 'PT Sans';
}  .comment-reply-title {
 font-size: 24px;
 }  blockquote {
 color: inherit;
 font-family: inherit;
 font-size: inherit;
 font-style: normal;
 margin: 20px 20px 20px 20px;
 padding: 0 20px;
 position: relative;
}  @media screen and (max-width: 500px){
/* Hide above footer */
.site-above-footer-wrap {
display: none !important;
}
/* Hide below footer */
.site-below-footer-wrap {
display: none !important;
}
} </style></head><body itemtype='https://schema.org/WebPage' itemscope='itemscope' class="page-template-default page page-id-6337 ast-single-post ast-inherit-site-logo-transparent ast-hfb-header ast-desktop ast-separate-container ast-two-container ast-no-sidebar astra-3.7.6 ast-full-width-layout ast-sticky-header-shrink ast-inherit-site-logo-sticky ast-normal-title-enabled astra-addon-3.6.3"> <a
 class="skip-link screen-reader-text"
 href="#content"
 role="link"
 title="Skip to content"> Skip to content</a><div
class="hfeed site" id="page"><header
 class="site-header header-main-layout-1 ast-primary-menu-enabled ast-hide-custom-menu-mobile ast-builder-menu-toggle-icon ast-mobile-header-inline" id="masthead" itemtype="https://schema.org/WPHeader" itemscope="itemscope" itemid="#masthead"		><div id="ast-desktop-header" data-toggle-type="dropdown"><div class="ast-above-header-wrap  "><div class="ast-above-header-bar ast-above-header  site-header-focus-item" data-section="section-above-header-builder"><div class="site-above-header-wrap ast-builder-grid-row-container site-header-focus-item ast-container" data-section="section-above-header-builder"><div class="ast-builder-grid-row ast-builder-grid-row-has-sides ast-builder-grid-row-no-center"><div class="site-header-above-section-left site-header-section ast-flex site-header-section-left"><div class="ast-builder-layout-element ast-flex site-header-focus-item" data-section="title_tagline"><div
 class="site-branding ast-site-identity" itemtype="https://schema.org/Organization" itemscope="itemscope"				> <span class="site-logo-img"></span><div class="ast-site-title-wrap"> <span class="site-title" itemprop="name"> <a href="https://www.logicmatters.net/" rel="home" itemprop="url" > Logic Matters </a> </span></div></div> <!-- .site-branding --></div></div><div class="site-header-above-section-right site-header-section ast-flex ast-grid-right-section"></div></div></div></div></div><div class="ast-main-header-wrap main-header-bar-wrap "><div class="ast-primary-header-bar ast-primary-header main-header-bar site-header-focus-item" data-section="section-primary-header-builder"><div class="site-primary-header-wrap ast-builder-grid-row-container site-header-focus-item ast-container" data-section="section-primary-header-builder"><div class="ast-builder-grid-row ast-builder-grid-row-has-sides ast-builder-grid-row-no-center"><div class="site-header-primary-section-left site-header-section ast-flex site-header-section-left"><div class="ast-builder-menu-1 ast-builder-menu ast-flex ast-builder-menu-1-focus-item ast-builder-layout-element site-header-focus-item" data-section="section-hb-menu-1"><div class="ast-main-header-bar-alignment"><div class="main-header-bar-navigation"><nav class="site-navigation ast-flex-grow-1 navigation-accessibility site-header-focus-item" id="primary-site-navigation" aria-label="Site Navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope"><div class="main-navigation ast-inline-flex"><ul id="ast-hf-menu-1" class="main-header-menu ast-menu-shadow ast-nav-menu ast-flex  submenu-with-border stack-on-mobile ast-mega-menu-enabled"><li id="menu-item-12658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-12658"><a href="https://www.logicmatters.net/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">MAIN SITE >></span><span class="sub-arrow"></span></a></li><li id="menu-item-12657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12657"><a href="https://www.logicmatters.net/blog/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">BLOG</span><span class="sub-arrow"></span></a></li><li id="menu-item-12660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12660"><a href="https://www.logicmatters.net/ifl/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">IFL</span><span class="sub-arrow"></span></a></li><li id="menu-item-12654" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12654"><a href="https://www.logicmatters.net/igt/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">GÖDEL</span><span class="sub-arrow"></span></a></li><li id="menu-item-12662" class="menu-item menu-item-type-post_type menu-item-object-page current-menu-item page_item page-item-6337 current_page_item menu-item-12662"><a href="https://www.logicmatters.net/categories/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">CATS</span><span class="sub-arrow"></span></a></li><li id="menu-item-12659" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12659"><a href="https://www.logicmatters.net/tyl/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">TYL</span><span class="sub-arrow"></span></a></li><li id="menu-item-12656" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12656"><a href="https://www.logicmatters.net/yet-more-logic/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">VARIA</span><span class="sub-arrow"></span></a></li><li id="menu-item-12655" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12655"><a href="https://www.logicmatters.net/latex-for-logicians/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">LaTeX</span><span class="sub-arrow"></span></a></li><li id="menu-item-12653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12653"><a href="https://www.logicmatters.net/about/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">About PS</span><span class="sub-arrow"></span></a></li></ul></div></nav></div></div></div></div><div class="site-header-primary-section-right site-header-section ast-flex ast-grid-right-section"><div class="ast-builder-layout-element ast-flex site-header-focus-item ast-header-search" data-section="section-header-search"><div class="ast-search-menu-icon slide-search"  tabindex="-1"><div class="ast-search-icon"> <a class="slide-search astra-search-icon" aria-label="Search icon link" href="#"> <span class="screen-reader-text">Search</span> <span class="ast-icon icon-search"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" viewBox="-888 480 142 142" enable-background="new -888 480 142 142" xml:space="preserve"> <path d="M-787.4,568.7h-6.3l-2.4-2.4c7.9-8.7,12.6-20.5,12.6-33.1c0-28.4-22.9-51.3-51.3-51.3  c-28.4,0-51.3,22.9-51.3,51.3c0,28.4,22.9,51.3,51.3,51.3c12.6,0,24.4-4.7,33.1-12.6l2.4,2.4v6.3l39.4,39.4l11.8-11.8L-787.4,568.7  L-787.4,568.7z M-834.7,568.7c-19.7,0-35.5-15.8-35.5-35.5c0-19.7,15.8-35.5,35.5-35.5c19.7,0,35.5,15.8,35.5,35.5  C-799.3,553-815,568.7-834.7,568.7L-834.7,568.7z"/> </svg></span> </a></div><form role="search" method="get" class="search-form" action="https://www.logicmatters.net/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field"  placeholder="Search &hellip;" value="" name="s" tabindex="-1"> <button class="search-submit ast-search-submit" aria-label="Search Submit"> <span hidden>Search</span> <i><span class="ast-icon icon-search"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" viewBox="-888 480 142 142" enable-background="new -888 480 142 142" xml:space="preserve"> <path d="M-787.4,568.7h-6.3l-2.4-2.4c7.9-8.7,12.6-20.5,12.6-33.1c0-28.4-22.9-51.3-51.3-51.3  c-28.4,0-51.3,22.9-51.3,51.3c0,28.4,22.9,51.3,51.3,51.3c12.6,0,24.4-4.7,33.1-12.6l2.4,2.4v6.3l39.4,39.4l11.8-11.8L-787.4,568.7  L-787.4,568.7z M-834.7,568.7c-19.7,0-35.5-15.8-35.5-35.5c0-19.7,15.8-35.5,35.5-35.5c19.7,0,35.5,15.8,35.5,35.5  C-799.3,553-815,568.7-834.7,568.7L-834.7,568.7z"/> </svg></span></i> </button> </label></form></div></div></div></div></div></div></div><div class="ast-desktop-header-content content-align-flex-start "><div class="ast-builder-menu-mobile ast-builder-menu ast-builder-menu-mobile-focus-item ast-builder-layout-element site-header-focus-item" data-section="section-header-mobile-menu"><div class="ast-main-header-bar-alignment"><div class="main-header-bar-navigation"><nav class="site-navigation ast-flex-grow-1 navigation-accessibility site-header-focus-item" id="ast-desktop-site-navigation" aria-label="Site Navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope"><div class="main-navigation"><ul id="ast-desktop-toggle-menu" class="main-header-menu ast-nav-menu ast-flex  submenu-with-border astra-menu-animation-fade  stack-on-mobile ast-mega-menu-enabled"><li id="menu-item-12882" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-12882"><a href="https://www.logicmatters.net/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Home</span></a></li><li id="menu-item-12883" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12883"><a href="https://www.logicmatters.net/blog/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Blog</span></a></li><li id="menu-item-12884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12884"><a href="https://www.logicmatters.net/ifl/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Formal Logic</span></a></li><li id="menu-item-12885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12885"><a href="https://www.logicmatters.net/igt/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Gödel’s Theorems</span></a></li><li id="menu-item-12889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12889"><a href="https://www.logicmatters.net/tyl/category-theory/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Category theory</span></a></li><li id="menu-item-12888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12888"><a href="https://www.logicmatters.net/tyl/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Teach Yourself Logic</span></a></li><li id="menu-item-12887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12887"><a href="https://www.logicmatters.net/yet-more-logic/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Papers, etc.</span></a></li><li id="menu-item-12886" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-12886"><a href="https://www.logicmatters.net/latex-for-logicians/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">LaTeX for Logicians<span role="presentation" class="dropdown-menu-toggle" tabindex="0" ></span></span><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span></a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span></button><ul class="sub-menu"><li id="menu-item-12902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12902"><a href="https://www.logicmatters.net/latex-for-logicians/general/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">General info</span></a></li><li id="menu-item-12903" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12903"><a href="https://www.logicmatters.net/latex-for-logicians/symbols/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Logic Symbols</span></a></li><li id="menu-item-12904" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12904"><a href="https://www.logicmatters.net/latex-for-logicians/nd/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Natural deduction</span></a></li><li id="menu-item-12901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12901"><a href="https://www.logicmatters.net/latex-for-logicians/trees/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Tree proofs</span></a></li><li id="menu-item-12905" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12905"><a href="https://www.logicmatters.net/latex-for-logicians/diagrams/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Diagrams</span></a></li><li id="menu-item-12906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12906"><a href="https://www.logicmatters.net/latex-for-logicians/miscellany/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Logicians’ miscellany</span></a></li><li id="menu-item-12907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12907"><a href="https://www.logicmatters.net/latex-for-logicians/classroom/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Conference/classroom</span></a></li></ul></li></ul></div></nav></div></div></div></div></div> <!-- Main Header Bar Wrap --><div id="ast-mobile-header" class="ast-mobile-header-wrap " data-type="dropdown"><div class="ast-main-header-wrap main-header-bar-wrap" ><div class="ast-primary-header-bar ast-primary-header main-header-bar site-primary-header-wrap site-header-focus-item ast-builder-grid-row-layout-default ast-builder-grid-row-tablet-layout-default ast-builder-grid-row-mobile-layout-default" data-section="section-primary-header-builder"><div class="ast-builder-grid-row ast-builder-grid-row-has-sides ast-builder-grid-row-no-center"><div class="site-header-primary-section-left site-header-section ast-flex site-header-section-left"><div class="ast-builder-layout-element ast-flex site-header-focus-item" data-section="title_tagline"><div
 class="site-branding ast-site-identity" itemtype="https://schema.org/Organization" itemscope="itemscope"				> <span class="site-logo-img"></span><div class="ast-site-title-wrap"> <span class="site-title" itemprop="name"> <a href="https://www.logicmatters.net/" rel="home" itemprop="url" > Logic Matters </a> </span></div></div> <!-- .site-branding --></div></div><div class="site-header-primary-section-right site-header-section ast-flex ast-grid-right-section"><div class="ast-builder-layout-element ast-flex site-header-focus-item" data-section="section-header-mobile-trigger"><div class="ast-button-wrap"> <button type="button" class="menu-toggle main-header-menu-toggle ast-mobile-menu-trigger-minimal"   aria-expanded="false"> <span class="screen-reader-text">Main Menu</span> <span class="mobile-menu-toggle-icon"> <span class="ahfb-svg-iconset ast-inline-flex svg-baseline"><svg class='ast-mobile-svg ast-menu2-svg' fill='currentColor' version='1.1' xmlns='http://www.w3.org/2000/svg' width='24' height='28' viewBox='0 0 24 28'><path d='M24 21v2c0 0.547-0.453 1-1 1h-22c-0.547 0-1-0.453-1-1v-2c0-0.547 0.453-1 1-1h22c0.547 0 1 0.453 1 1zM24 13v2c0 0.547-0.453 1-1 1h-22c-0.547 0-1-0.453-1-1v-2c0-0.547 0.453-1 1-1h22c0.547 0 1 0.453 1 1zM24 5v2c0 0.547-0.453 1-1 1h-22c-0.547 0-1-0.453-1-1v-2c0-0.547 0.453-1 1-1h22c0.547 0 1 0.453 1 1z'></path></svg></span><span class="ahfb-svg-iconset ast-inline-flex svg-baseline"><svg class='ast-mobile-svg ast-close-svg' fill='currentColor' version='1.1' xmlns='http://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path d='M5.293 6.707l5.293 5.293-5.293 5.293c-0.391 0.391-0.391 1.024 0 1.414s1.024 0.391 1.414 0l5.293-5.293 5.293 5.293c0.391 0.391 1.024 0.391 1.414 0s0.391-1.024 0-1.414l-5.293-5.293 5.293-5.293c0.391-0.391 0.391-1.024 0-1.414s-1.024-0.391-1.414 0l-5.293 5.293-5.293-5.293c-0.391-0.391-1.024-0.391-1.414 0s-0.391 1.024 0 1.414z'></path></svg></span> </span> </button></div></div><div class="ast-builder-layout-element ast-flex site-header-focus-item ast-header-search" data-section="section-header-search"><div class="ast-search-menu-icon slide-search"  tabindex="-1"><div class="ast-search-icon"> <a class="slide-search astra-search-icon" aria-label="Search icon link" href="#"> <span class="screen-reader-text">Search</span> <span class="ast-icon icon-search"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" viewBox="-888 480 142 142" enable-background="new -888 480 142 142" xml:space="preserve"> <path d="M-787.4,568.7h-6.3l-2.4-2.4c7.9-8.7,12.6-20.5,12.6-33.1c0-28.4-22.9-51.3-51.3-51.3  c-28.4,0-51.3,22.9-51.3,51.3c0,28.4,22.9,51.3,51.3,51.3c12.6,0,24.4-4.7,33.1-12.6l2.4,2.4v6.3l39.4,39.4l11.8-11.8L-787.4,568.7  L-787.4,568.7z M-834.7,568.7c-19.7,0-35.5-15.8-35.5-35.5c0-19.7,15.8-35.5,35.5-35.5c19.7,0,35.5,15.8,35.5,35.5  C-799.3,553-815,568.7-834.7,568.7L-834.7,568.7z"/> </svg></span> </a></div><form role="search" method="get" class="search-form" action="https://www.logicmatters.net/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field"  placeholder="Search &hellip;" value="" name="s" tabindex="-1"> <button class="search-submit ast-search-submit" aria-label="Search Submit"> <span hidden>Search</span> <i><span class="ast-icon icon-search"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" viewBox="-888 480 142 142" enable-background="new -888 480 142 142" xml:space="preserve"> <path d="M-787.4,568.7h-6.3l-2.4-2.4c7.9-8.7,12.6-20.5,12.6-33.1c0-28.4-22.9-51.3-51.3-51.3  c-28.4,0-51.3,22.9-51.3,51.3c0,28.4,22.9,51.3,51.3,51.3c12.6,0,24.4-4.7,33.1-12.6l2.4,2.4v6.3l39.4,39.4l11.8-11.8L-787.4,568.7  L-787.4,568.7z M-834.7,568.7c-19.7,0-35.5-15.8-35.5-35.5c0-19.7,15.8-35.5,35.5-35.5c19.7,0,35.5,15.8,35.5,35.5  C-799.3,553-815,568.7-834.7,568.7L-834.7,568.7z"/> </svg></span></i> </button> </label></form></div></div></div></div></div></div><div class="ast-mobile-header-content content-align-flex-start "><div class="ast-builder-menu-mobile ast-builder-menu ast-builder-menu-mobile-focus-item ast-builder-layout-element site-header-focus-item" data-section="section-header-mobile-menu"><div class="ast-main-header-bar-alignment"><div class="main-header-bar-navigation"><nav class="site-navigation ast-flex-grow-1 navigation-accessibility site-header-focus-item" id="ast-mobile-site-navigation" aria-label="Site Navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope"><div class="main-navigation"><ul id="ast-hf-mobile-menu" class="main-header-menu ast-nav-menu ast-flex  submenu-with-border astra-menu-animation-fade  stack-on-mobile ast-mega-menu-enabled"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-12882"><a href="https://www.logicmatters.net/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Home</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12883"><a href="https://www.logicmatters.net/blog/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Blog</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12884"><a href="https://www.logicmatters.net/ifl/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Formal Logic</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12885"><a href="https://www.logicmatters.net/igt/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Gödel’s Theorems</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12889"><a href="https://www.logicmatters.net/tyl/category-theory/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Category theory</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12888"><a href="https://www.logicmatters.net/tyl/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Teach Yourself Logic</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12887"><a href="https://www.logicmatters.net/yet-more-logic/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Papers, etc.</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-12886"><a href="https://www.logicmatters.net/latex-for-logicians/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">LaTeX for Logicians<span role="presentation" class="dropdown-menu-toggle" tabindex="0" ></span></span><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span></a><button class="ast-menu-toggle" aria-expanded="false"><span class="screen-reader-text">Menu Toggle</span><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span></button><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12902"><a href="https://www.logicmatters.net/latex-for-logicians/general/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">General info</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12903"><a href="https://www.logicmatters.net/latex-for-logicians/symbols/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Logic Symbols</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12904"><a href="https://www.logicmatters.net/latex-for-logicians/nd/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Natural deduction</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12901"><a href="https://www.logicmatters.net/latex-for-logicians/trees/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Tree proofs</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12905"><a href="https://www.logicmatters.net/latex-for-logicians/diagrams/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Diagrams</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12906"><a href="https://www.logicmatters.net/latex-for-logicians/miscellany/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Logicians’ miscellany</span></a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12907"><a href="https://www.logicmatters.net/latex-for-logicians/classroom/" class="menu-link"><span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span><span class="menu-text">Conference/classroom</span></a></li></ul></li></ul></div></nav></div></div></div></div></div></header><!-- #masthead --><div id="content" class="site-content"><div class="ast-container"><div id="primary" class="content-area primary"><main id="main" class="site-main"><article
class="post-6337 page type-page status-publish ast-article-single" id="post-6337" itemtype="https://schema.org/CreativeWork" itemscope="itemscope"><header class="entry-header ast-no-thumbnail ast-no-meta"><h1 class="entry-title" itemprop="headline">Category Theory: Lecture Notes and Online Books</h1></header><!-- .entry-header --><div class="entry-content clear" 
 itemprop="text"	><hr /><p>The links below are to various freely (and legitimately!) available online mathematical resources for those interested in category theory at an elementary/intermediate level.</p><p>There is supplementary page,<strong> <a href="/tyl/category-theory/">introductory readings for philosophers</a></strong>, for reading suggestions for those looking for the most accessible routes into category theory and/or links to philosophical discussions.</p><hr /><h2><span style="color: #666666;">A gentle introduction?</span></h2><p>My <strong> <a href="/resources/pdfs/GentleIntro.pdf">Category Theory: A Gentle Introduction</a></strong> is intended to be relatively accessible; in particular, it presupposes rather less mathematical background than some texts on categories. The version of January 29, 2018 is x + 291 pp. long, and is very much work-in-slow-progress, at an uneven level. I then had to leave it on the back burner while finishing of <em>IFL2</em> for the press: but I now hope to return to it.</p><p>The current version incorporates a raft of corrections of the previous version, but everything of course still comes with the warning <em>caveat lector</em>. However, although I started writing really as an exercise in getting myself a bit clearer about some basic category theory, I hope that others will find something of interest and use here. Obviously I&#8217;d very much welcome comments and corrections.</p><p>There are a lot of possible follow-up materials listed here. But if you want something just a step or two up from my notes but still tolerably gentle, let me highlight two books listed below. One is Steve Awodey&#8217;s <em>Category Theory</em> (chapters available <a href="http://www.andrew.cmu.edu/course/80-413-713/notes/?C=M;O=A">on his website here</a>). The other is Tom Leinster&#8217;s <a href="https://arxiv.org/abs/1612.09375"><em>Basic Category Theory</em></a>.</p><hr /><h2><span style="color: #666666;">Lecture notes on Category Theory</span></h2><p><span style="color: #666666;"><strong>Notes of P.T. Johnstone&#8217;s Lectures</strong></span> for the Cambridge Part III course:</p><ol><li style="list-style-type: none;"><ol><li><a href="https://pi.math.cornell.edu/~bfontain/cattheory.pdf">Notes by Bruce Fontaine</a> (pp. 52: version of Nov. 2011).</li><li><a href="http://pi.math.cornell.edu/~dmehrle/notes/partiii/cattheory_partiii_notes.pdf">Notes by David Mehrle</a> (pp. 80; lectures given 2015, notes revised 2016).</li><li><a href="http://qk206.user.srcf.net/notes/category_theory.pdf">Notes by Qiangru Kuang</a> (pp. 68, 2018)</li></ol></li></ol><p><span style="color: #666666;"><strong>Other online notes</strong></span> An idiosyncratic list of notes/expositions of various styles that I happen to have come across that might in varying degrees be useful (I&#8217;ve only listed the more substantial lecture notes available).  In alphabetical order:</p><ol><!---<li>Michael Barr and Charles Wells, <a href="http://synrc.com/publications/cat/Category%20Theory/General%20Theory/Barr,%20Wells.%20Category%20Theory.pdf">Category Theory: Lecture Notes for ESSLLI</a> (pp. 133, 1999: a condensation of their excellent book <em>Category Theory for Computing Science </em>which is also available online: see below).</li> <span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start"></span><li>Ana Agore, <a href="http://homepages.vub.ac.be/~aagore/files/Lectures.pdf">Lecture notes on category theory</a> (pp. 80, 2016-17).</li> --></p><li>John Baez, <a href="http://math.ucr.edu/home/baez/qg-winter2016/CategoryTheoryNotes.pdf">Category Theory Course</a> (pp. 59, 2019: past course page <a href="https://golem.ph.utexas.edu/category/2016/03/category_theory_course.html">here</a>).</li><li>Michael Barr and Charles Wells, <a href="http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.98.9012&amp;rep=rep1&amp;type=pdf">Category Theory Lecture Notes for ESSLLI</a> (pp. 128, 1999: a cut down version of their <em>Category Theory for Computing Science</em>.)</li><li>Mario Cáccamo and Glynn Winskel, <a href="http://www.cl.cam.ac.uk/~gw104/catnotes.ps">Lecture Notes on Category Theory</a> (postscript file, pp. 74, 2005: notes for a course inspired by Martin Hyland&#8217;s Part III Mathematics course ).</li><li>Robin Cockett, <a href="http://pages.cpsc.ucalgary.ca/~robin/class/617/notes.pdf">Category Theory for Computer Science</a> (pp. 107, 2016). And by the same author, a significantly different set of notes <a href="http://pages.cpsc.ucalgary.ca/~robin/talks/estonia-winter-2010/estonia-notes.pdf">Categories and Computability</a> (pp. 100, 2014).</li><li>Rafael Villarroel Flores, <a href="http://mimosa.pntic.mec.es/jgomez53/matema/docums/villarroel-categories.pdf">Notes on Categories</a> (pp. 77, 2004).</li><li>Maarten M. Fokkinga, <a href="https://maartenfokkinga.github.io/utwente/mmf92b.pdf">A Gentle Introduction to Category Theory: The Calculational Approach</a> (pp. 78, 1994).</li><li>Julia Goedecke, <a href="http://www.julia-goedecke.de/pdf/CategoryTheoryNotes.pdf">Category Theory</a> (pp. 63, lecture notes for her Cambridge Part III Maths course, 2013: related materials on her <a href="http://www.julia-goedecke.de/teaching.html">website here</a>).</li><li>Randal Holmes, <a href="https://web.auburn.edu/holmerr/8970/Textbook/CategoryTheory.pdf">Category Theory</a> (pp. 99, 2019).</li><li>Chris Hillman, <a href="http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.24.3264&amp;rep=rep1&amp;type=pdf">A Categorical Primer</a> (pp. 62, 1997).</li><li>Robert Knighten, <a href="http://robert.knighten.org/Documents/Notes.pdf">Notes on Category Theory</a> (about pp. 160 of unfinished notes, followed by appendices including useful information about many books: 2011).</li><li>Valdis Laan, <a href="http://www.algebra.uni-linz.ac.at/Students/Categories/Linzcat.pdf">Introduction to Category Theory</a> (pp. 52, 2003).</li><li>Bartosz Milewski, <a href="http://bartoszmilewski.com/2014/10/28/category-theory-for-programmers-the-preface/">Category Theory for Programmers</a> (series of long blogposts, available in book format, linked below: also see also his videos, also linked below).</li><li>Ed Morehouse,  <a href="http://emorehouse.web.wesleyan.edu/research/notes/basic_category_theory.pdf">Basic Category Theory</a> (pp. 77, 2016).</li><li>Jaap van Oosten, <a href="http://www.staff.science.uu.nl/~ooste110/syllabi/cattop16.pdf">Basic Category Theory and Topos Theory</a> (pp. 123, Utrecht 2016).</li><li>Paulo Perrone, <a href="http://www.paoloperrone.org/ct-notes.pdf">Notes on Category Theory</a> (pp. 132, 2019)</li><li>Benjamin Pierce, <a href="http://people.csail.mit.edu/jgross/personal-website/papers/academic-papers-local/repository.cmu.edu__cgi__viewcontent.cgi_article=2846_context=compsci.pdf">A Taste of Category Theory for Computer Scientist</a>s (pp. 75, 1988: earlier version of <a href="https://mitpress.mit.edu/books/basic-category-theory-computer-scientists">this book</a>).</li><li>Prakash Panangaden, <a href="http://www.cs.mcgill.ca/~prakash/Pubs/category_theory_notes.pdf">Brief notes on category theory</a> (pp. 36, 2012).</li><li>Uday S. Reddy, <a href="http://events.cs.bham.ac.uk/mgs2012/lectures/ReddyNotes.pdf">Categories and Functors</a> (pp. 47, Lecture Notes for Midlands Graduate School, 2012).</li><li><span class="citation book">Andrea Schalk and Harold Simmons, <a class="external text" href="http://www.cs.man.ac.uk/~hsimmons/BOOKS/CatTheory.pdf" rel="nofollow">An Introduction to Category Theory, in four easy movements</a> (pp. 126, plus solutions of exercises: 2005 notes </span>for an MSc course in math. logic).</li><li>Pavel Safronov, <a href="https://drive.google.com/file/d/0B3Hq3GkR_m3iSkpjcnVuRjhEZFU/view">Category Theory</a> (pp. 56 &#8212; Oxford lecture notes, 2015).</li><li>Pierre Schapira, <a href="https://webusers.imj-prg.fr/~pierre.schapira/lectnotes/AlTo.pdf">Algebra and Topology</a> (pp. 157, 2008 &#8212; largely category theory).</li><li>Pierre Schapira, <a href="http://webusers.imj-prg.fr/~pierre.schapira/lectnotes/HomAl.pdf">Categories and Homological Algebra</a> (pp. 120, 2002-15: presupposes some background in algebra etc., but fairly introductory on categories).</li><li>William R. Schmitt, <a href="http://home.gwu.edu/~wschmitt/papers/cat.pdf">A Concrete Introduction to Categories</a> (pp. 60).</li><li>Greg Stevenson, <a href="http://www.maths.gla.ac.uk/~gstevenson/cat-notes.pdf">Rudimentary Category Theory Notes (</a>pp. 28).</li><li>Thomas Streicher, <a href="http://www.mathematik.tu-darmstadt.de/~streicher/CTCL.pdf">Introduction to Category Theory and Categorial Logic</a> (pp. 116, 2003/4).</li><li>Daniele Turi, <a href="http://www.dcs.ed.ac.uk/home/dt/CT/categories.pdf">Category Theory Lecture Notes</a> (pp. 58, Edinburgh, 2001).</li><li>Ravi Vakil, Some category theory (pp. 57: from Ch. 1 of <em>The Rising Sea: Foundations Of Algebraic Geometry Notes.</em> Latest version <a href="http://math.stanford.edu/~vakil/216blog/">available here</a>, 2017).</li></ol><hr /><h2><span style="color: #666666;">Books and Articles on Category Theory</span></h2><p><span style="color: #666666;"><strong>Some books and other longer published works on category theory</strong></span> These are e-copies of paper publications, at introductory or intermediate level, which happen also to be <em>officially</em> available to download.</p><ol><li>Samson Abramsky and Nikos Tzevelekos,<a href="http://arxiv.org/pdf/1102.1313v1.pdf"> Introduction to Categories and Categorical Logic </a> (pp. 101: 2011 arXiv version of their chapter in Bob Coecke, ed. <em>New Structures for Physics</em>, Springer 2010).</li><li>Jiri Adamek, Horst Herrlich and George Strecker, <a href="http://tac.mta.ca/tac/reprints/articles/17/tr17.pdf"><em>Abstract and Concrete Categories: The Joy of Cats</em></a> (originally published John Wiley and Sons, 1990: recommended).</li><li>Andrea Asperti and Giuseppe Longo. <a href="http://www.di.ens.fr/users/longo/files/CategTypesStructures/book.pdf"><em>Categories, Types and Structures: Category Theory for the working computer scientist</em></a>. MIT Press, 1991.</li><li>Steve Awodey, <em>Category Theory</em> (versions of the chapters from the 2010 second edition of this useful book in the Oxford Logic Guides <a href="http://www.andrew.cmu.edu/course/80-413-713/notes/?C=M;O=A">available here</a>).</li><li>Michael Barr and Charles Wells, <em><a href="http://www.tac.mta.ca/tac/reprints/articles/12/tr12.pdf">Toposes, Triples and Theories</a></em> (originally published Springer, 1985).</li><li>Michael Barr and Charles Wells, <em><a href="http://www.tac.mta.ca/tac/reprints/articles/22/tr22.pdf">Category Theory for Computing Science</a></em> (originally published Prentice Hall, 1995: particularly clear and useful).</li><li>George M. Bergman,<a href="https://math.berkeley.edu/~gbergman/245/3.2.pdf"><em> An Invitation to General Algebra and Universal Constructions</em> </a>(online version of book published by Springer, 2nd end 2015: this is about recurrent ideas in algebra and the way category theory unifies them).</li><li>Brendan Fong and David Spivak,<a href="http://math.mit.edu/~dspivak/teaching/sp18/7Sketches.pdf"> Seven Sketches in Compositionality:An Invitation to Applied Category Theory</a> (pp. 341, 2018: published  as CUP book in 2019).</li><li>Peter Freyd, <a href="http://www.tac.mta.ca/tac/reprints/articles/3/tr3abs.html"><em>Abelian Categories</em></a> (originally published Harper and Row, 1964: not exactly elementary &#8212; but a classic).</li><li>Robert Goldblatt, <em><a href="https://projecteuclid.org/euclid.bia/1403013939#toc-idx?c=math;idno=gold010">Topoi</a></em> (originally published North-Holland, 1979/1984: an expository classic – also available as cheap Dover book).</li><li>Horst Herrlich and George Strecker, <i><a href="http://www.heldermann.de/SSPM/SSPM01/sspm01.htm">Category Theory</a> </i>(originally published Allyn and Bacon, 1973; third edition 2007: more introductory than their later book with Adamek listed above.)</li><li>Tom Leinster, <a href="https://arxiv.org/abs/1612.09375"><em>Basic Category Theory</em></a> (originally published CUP, 2014).</li><li>Bartosz Milewski, <a href="https://github.com/hmemcpy/milewski-ctfp-pdf/"><em>Category Theory for Programmers</em></a> (book version of his blog posts, 2018)</li><li>Bodo Pareigis, <em><a href="http://epub.ub.uni-muenchen.de/7244/1/7244.pdf">Categories and Functors</a></em> (originally published Academic Press, 1970).</li><li>Birgit Richter, <a href="https://www.math.uni-hamburg.de/home/richter/bookdraft.pdf"><em>From Categories to Homotopy Theory</em></a> (pp. 327, 2019: to be published by CUP in 2020: stretching a point to include this as it gets advanced, but it starts off relatively accessibly).</li><li>Emily Riehl, <em><a href="http://www.math.jhu.edu/~eriehl/context.pdf">Category Theory in Context</a></em> (pp. 240: 2016 version of  her <a href="http://www.math.jhu.edu/~eriehl/727/">lecture course at Johns Hopkins</a>, now published as a Dover book).</li><li>Andrei Rodin, <em><a href="http://arxiv.org/pdf/1210.1478v1.pdf">Axiomatic Method and Category Theory</a></em> (2012 arXiv version of book published by Springer 2104: not an exposition of category theory but discusses something of the history and philosophy behind its development).</li><li>D.E. Rydeheard and R.M. Burstall, <a href="http://www.cs.man.ac.uk/~david/categories/book/book.ps"><i>Computational Category Theory</i>.</a> (postscript file: originally published Prentice-Hall, 1988).</li><li>Harold Simmons, <a href="http://dl.icdst.org/pdfs/files3/589bdb0ed138159a2b3e5ccb4268a9f9.pdf"><em>An Introduction to Category Theory</em> </a>(late version of book published by CUP, 2011: includes answers to most of the exercises).</li><li>David I. Spivak, <a href="https://ocw.mit.edu/courses/mathematics/18-s996-category-theory-for-scientists-spring-2013/textbook/MIT18_S996S13_textbook.pdf"><em>Category Theory for the Science</em></a><a href="http://math.mit.edu/~dspivak/"><em>s</em></a> (online version of book published by MIT Press, 2014)</li></ol><p><span style="color: #666666;"><strong>Some handbook essays on categorial logic in particular</strong></span></p><ol><li>Samson Abramsky and Nikos Tzevelekos,<a href="http://arxiv.org/pdf/1102.1313v1.pdf"> Introduction to Categories and Categorical Logic </a> (as above). [Clear intro. to categories: but when it turns to logic rather rushed and oddly focused.]</li><li>John L. Bell, <a href="http://publish.uwo.ca/~jbell/catlogprime.pdf">The Development of Categorical Logic</a> (more advanced: published in D.M. Gabbay &amp; Franz Guenthner, eds, <em>Handbook of Philosophical Logic</em>, 2nd edition, Volume 12, Springer 2005).</li><li>Jean-Pierre Marquis &amp; Gonzalo E. Reyes, <a href="https://www.webdepot.umontreal.ca/Usagers/marquisj/MonDepotPublic/HistofCatLog.pdf">The History Of Categorical Logic 1963 1977 </a>(in Dov Gabbay et al., eds, <i>Handbook of the History of Logic Vol 6: Sets and extensions in the twentieth century, </i>North-Holland 2012). [Over-detailed and consequently rather impenetrable: probably only useful if you already know a lot.]</li><li>Andrew Pitts, <a href="https://www.cl.cam.ac.uk/techreports/UCAM-CL-TR-367.ps.gz">Categorical Logic</a> (in S. Abramsky, D. Gabbay, T. Maibaum, eds, <em>Handbook of Logic in Computer Science</em> Vol 5, OUP 2000).</li></ol><p><span style="color: #666666;"><strong>Page of links to reprints, including some classic articles </strong></span></p><ul style="list-style-type: none;"><li><a href="http://www.tac.mta.ca/tac/reprints/">Reprints in Theory and Applications of Categories</a></li></ul><p><strong>Web resource</strong></p><p>I can&#8217;t finish listing text resources without mentioning the massively useful wiki, the <a href="https://ncatlab.org/nlab/show/HomePage">nLab</a>. See in particular <a href="https://ncatlab.org/nlab/show/category+theory">category theory in nLab</a>.</p><hr /><h2><span style="color: #666666;">Videos</span></h2><ol><li>There is a fun and instructive series at an introductory level by <a href="http://www.simonwillerton.staff.shef.ac.uk/TheCatsters/">The Catsters</a> (Eugenia Cheng and Simon Willerton).</li><li><a href="https://www.youtube.com/playlist?list=PLGCr8P_YncjVjwAxrifKgcQYtbZ3zuPlb">Steve Awodey</a> has an excellent series, aimed a little higher (with a compsci flavour), going a little further.</li><li><a href="https://ocw.mit.edu/courses/mathematics/18-s097-applied-category-theory-january-iap-2019/lecture-videos-and-readings/index.htm">B. Fong and D. Spivak</a>: elementary lectures on applied category theory.</li><li><a href="https://www.youtube.com/playlist?list=PLbgaMIhjbmEnaH_LTkxLI7FMa2HsnawM_">Bartosz Milewski</a> has a series of videos (again with a compsci flavour).</li><li><a href="https://www.youtube.com/playlist?list=PLiHLLF-foEexKDi7tmiO5tP8Uxt0ueK-L">Ed Morehouse</a>: four basic level lectures to accompany his 2016 notes listed above.</li></ol><hr /><p>I have only listed here material of roughly the right level that is, to repeat, <em>officially</em> available online (I have omitted links to some short sets of notes, and we must here pass over in silence copyright-infringing repositories). I don&#8217;t plan to be completist &#8212; but do please let me know of errors and omissions and newly available lecture notes, etc.</p><p><em>Links last checked, deleted, revised, and </em><em>added 26 November 2019</em></p><hr /></div><!-- .entry-content .clear --></article><!-- #post-## --><div id="comments" class="comments-area"><h3 class="comments-title"> 16 thoughts on &ldquo;Category Theory: Lecture Notes and Online Books&rdquo;</h3><ol class="ast-comment-list"><li class="comment even thread-even depth-1" id="li-comment-4557430888798924826"><article id="comment-4557430888798924826" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn">Mozibur Ullah</b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798924826"><time datetime="2015-03-12T18:08:23+00:00">March 12, 2015 at 6:08 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>How about Lawveres and Schanuels book &#8211; Sets for mathematicians? and if I&#8217;m not mistaken Maclanes book Categories for the working mathematician is not in your list!</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798924826' data-commentid="4557430888798924826" data-postid="6337" data-belowelement="comment-4557430888798924826" data-respondelement="respond" data-replyto="Reply to Mozibur Ullah" aria-label='Reply to Mozibur Ullah'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --><ol class="children"><li class="comment byuser comment-author-petersmith bypostauthor odd alt depth-2" id="li-comment-4557430888798924827"><article id="comment-4557430888798924827" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://logicmatters.net' rel='external nofollow ugc' class='url'>Peter Smith</a></b> <span class="ast-highlight-text ast-cmt-post-author"></span></cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798924827"><time datetime="2015-03-12T18:48:21+00:00">March 12, 2015 at 6:48 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>These are links to books which are freely and legally available to download.  Neither Lawvere and Schanuel, nor Mac Lane, are thus available. Both books however are mentioned in the <a href="https://logicmatters.net/tyl/category-theory/" rel="nofollow">linked reading list</a>.</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798924827' data-commentid="4557430888798924827" data-postid="6337" data-belowelement="comment-4557430888798924827" data-respondelement="respond" data-replyto="Reply to Peter Smith" aria-label='Reply to Peter Smith'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --></ol><!-- .children --></li><!-- #comment-## --><li class="comment even thread-odd thread-alt depth-1" id="li-comment-4557430888798935944"><article id="comment-4557430888798935944" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://www.dpmms.cam.ac.uk/~jg352/teaching.html' rel='external nofollow ugc' class='url'>Julia Goedecke</a></b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798935944"><time datetime="2015-10-20T17:00:35+01:00">October 20, 2015 at 5:00 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>People might also be interested in other material available on my teaching page from when I lectured the course in 2013. Such as lots of extra examples, and some video solutions to some easy exercises. <a href="https://www.dpmms.cam.ac.uk/~jg352/teaching.html" rel="nofollow ugc">https://www.dpmms.cam.ac.uk/~jg352/teaching.html</a></p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798935944' data-commentid="4557430888798935944" data-postid="6337" data-belowelement="comment-4557430888798935944" data-respondelement="respond" data-replyto="Reply to Julia Goedecke" aria-label='Reply to Julia Goedecke'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --><ol class="children"><li class="comment byuser comment-author-petersmith bypostauthor odd alt depth-2" id="li-comment-4557430888798935945"><article id="comment-4557430888798935945" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://logicmatters.net' rel='external nofollow ugc' class='url'>Peter Smith</a></b> <span class="ast-highlight-text ast-cmt-post-author"></span></cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798935945"><time datetime="2015-10-20T17:09:32+01:00">October 20, 2015 at 5:09 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Yes, thanks, I indeed should have linked this before!</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798935945' data-commentid="4557430888798935945" data-postid="6337" data-belowelement="comment-4557430888798935945" data-respondelement="respond" data-replyto="Reply to Peter Smith" aria-label='Reply to Peter Smith'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --></ol><!-- .children --></li><!-- #comment-## --><li class="comment even thread-even depth-1" id="li-comment-4557430888798940503"><article id="comment-4557430888798940503" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://blaisorblade.github.io/' rel='external nofollow ugc' class='url'>Paolo G. Giarrusso</a></b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798940503"><time datetime="2016-02-08T22:58:25+00:00">February 8, 2016 at 10:58 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Would you please consider uploading versioned copies with permalinks? Maybe that&#8217;s overkill, but I just linked to theorem 68 of the current version of your notes — in this post:<br /> <a href="https://www.reddit.com/r/ocaml/comments/3ifwe9/what_are_ocamlers_critiques_of_haskell/czsri44" rel="nofollow ugc">https://www.reddit.com/r/ocaml/comments/3ifwe9/what_are_ocamlers_critiques_of_haskell/czsri44</a> (but I won&#8217;t try to explain what divergence means, it makes no sense unless you care about practical programming languages, as I also sometimes do).</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798940503' data-commentid="4557430888798940503" data-postid="6337" data-belowelement="comment-4557430888798940503" data-respondelement="respond" data-replyto="Reply to Paolo G. Giarrusso" aria-label='Reply to Paolo G. Giarrusso'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --><li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-4557430888798940727"><article id="comment-4557430888798940727" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn">Dion</b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798940727"><time datetime="2016-03-01T19:47:30+00:00">March 1, 2016 at 7:47 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Hi, nice blog and nice set of notes. Would you be so kind as to share the latex template you&#8217;re using to write &#8220;Category Theory: A gentle introduction&#8221;?</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798940727' data-commentid="4557430888798940727" data-postid="6337" data-belowelement="comment-4557430888798940727" data-respondelement="respond" data-replyto="Reply to Dion" aria-label='Reply to Dion'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --><ol class="children"><li class="comment byuser comment-author-petersmith bypostauthor even depth-2" id="li-comment-4557430888798945699"><article id="comment-4557430888798945699" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://logicmatters.net' rel='external nofollow ugc' class='url'>Peter Smith</a></b> <span class="ast-highlight-text ast-cmt-post-author"></span></cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798945699"><time datetime="2016-09-12T20:08:00+01:00">September 12, 2016 at 8:08 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>It&#8217;s just using the memoir class, with the default \pagestyle{ruled} with minor tweaks.</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798945699' data-commentid="4557430888798945699" data-postid="6337" data-belowelement="comment-4557430888798945699" data-respondelement="respond" data-replyto="Reply to Peter Smith" aria-label='Reply to Peter Smith'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --></ol><!-- .children --></li><!-- #comment-## --><li class="comment odd alt thread-even depth-1" id="li-comment-4557430888798940839"><article id="comment-4557430888798940839" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn">Fybove</b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798940839"><time datetime="2016-03-12T02:08:22+00:00">March 12, 2016 at 2:08 am</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>I just wanted to thank you Dr Smith for your notes on category theory, they get right the always difficult balance between depth and readibility. Without these it would have been almost impossible for me to give a talk at our undergraduate seminar on dual spaces and dual categories, being specially useful the discussion in the section on naturally isomorphic functors.</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798940839' data-commentid="4557430888798940839" data-postid="6337" data-belowelement="comment-4557430888798940839" data-respondelement="respond" data-replyto="Reply to Fybove" aria-label='Reply to Fybove'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --><li class="comment even thread-odd thread-alt depth-1" id="li-comment-4557430888798941208"><article id="comment-4557430888798941208" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn">Souvik Das</b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798941208"><time datetime="2016-04-25T15:17:37+01:00">April 25, 2016 at 3:17 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Will the final version of your notes on Category Theory still be available on this page? I mean, do you plan to remove the link when (if at all) these notes are transformed into a book like your An Introduction to Formal Logic?</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798941208' data-commentid="4557430888798941208" data-postid="6337" data-belowelement="comment-4557430888798941208" data-respondelement="respond" data-replyto="Reply to Souvik Das" aria-label='Reply to Souvik Das'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --><ol class="children"><li class="comment byuser comment-author-petersmith bypostauthor odd alt depth-2" id="li-comment-4557430888798941243"><article id="comment-4557430888798941243" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://logicmatters.net' rel='external nofollow ugc' class='url'>Peter Smith</a></b> <span class="ast-highlight-text ast-cmt-post-author"></span></cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798941243"><time datetime="2016-04-28T16:59:02+01:00">April 28, 2016 at 4:59 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Well, it&#8217;s a hopeful thought that there <em>will</em> be a final version! But if it does come to the point of official publication, I guess it would depend on arrangements with the publishers. (CUP is increasing allowing authors to leave late versions online, or to make their books available online after a certain interval.) But all that&#8217;s in the future &#8230; at the moment, things seem to be going a lot more slowly than I would like.</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798941243' data-commentid="4557430888798941243" data-postid="6337" data-belowelement="comment-4557430888798941243" data-respondelement="respond" data-replyto="Reply to Peter Smith" aria-label='Reply to Peter Smith'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --></ol><!-- .children --></li><!-- #comment-## --><li class="comment even thread-even depth-1" id="li-comment-4557430888798946225"><article id="comment-4557430888798946225" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='http://steshaw.org' rel='external nofollow ugc' class='url'>Steven Shaw</a></b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798946225"><time datetime="2016-09-25T04:19:37+01:00">September 25, 2016 at 4:19 am</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Bartosz Milewski now has a series of videos on youtube:</p><p><a href="https://www.youtube.com/playlist?list=PLbgaMIhjbmEnaH_LTkxLI7FMa2HsnawM_" rel="nofollow ugc">https://www.youtube.com/playlist?list=PLbgaMIhjbmEnaH_LTkxLI7FMa2HsnawM_</a></p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798946225' data-commentid="4557430888798946225" data-postid="6337" data-belowelement="comment-4557430888798946225" data-respondelement="respond" data-replyto="Reply to Steven Shaw" aria-label='Reply to Steven Shaw'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --><li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-4557430888798960440"><article id="comment-4557430888798960440" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn">Franky</b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798960440"><time datetime="2018-11-17T15:03:35+00:00">November 17, 2018 at 3:03 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Randall R. Holmes has a free Category Theory textbook.</p><p><a href="https://web.auburn.edu/holmerr/8970/Textbook/CategoryTheory.pdf" rel="nofollow ugc">https://web.auburn.edu/holmerr/8970/Textbook/CategoryTheory.pdf</a></p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798960440' data-commentid="4557430888798960440" data-postid="6337" data-belowelement="comment-4557430888798960440" data-respondelement="respond" data-replyto="Reply to Franky" aria-label='Reply to Franky'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --><ol class="children"><li class="comment byuser comment-author-petersmith bypostauthor even depth-2" id="li-comment-4557430888798964189"><article id="comment-4557430888798964189" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://logicmatters.net' rel='external nofollow ugc' class='url'>Peter Smith</a></b> <span class="ast-highlight-text ast-cmt-post-author"></span></cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798964189"><time datetime="2019-11-26T14:51:58+00:00">November 26, 2019 at 2:51 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>It&#8217;s linked &#8230; a bit arbitrarily under lecture notes rather than books.</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798964189' data-commentid="4557430888798964189" data-postid="6337" data-belowelement="comment-4557430888798964189" data-respondelement="respond" data-replyto="Reply to Peter Smith" aria-label='Reply to Peter Smith'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --></ol><!-- .children --></li><!-- #comment-## --><li class="comment odd alt thread-even depth-1" id="li-comment-4557430888798966423"><article id="comment-4557430888798966423" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn">Rowsety Moid</b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798966423"><time datetime="2020-10-14T23:58:38+01:00">October 14, 2020 at 11:58 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Just noticed this:</p><p><i>Topology: A Categorical Approach</i> by Tai-Danae Bradley, Tyler Bryson and John Terilla</p><p><a href="https://www.math3ma.com/blog/topology-book-launch" rel="nofollow ugc">https://www.math3ma.com/blog/topology-book-launch</a></p><p>Note link to a free open access version.  (You can download individual chapters as pdf.)</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798966423' data-commentid="4557430888798966423" data-postid="6337" data-belowelement="comment-4557430888798966423" data-respondelement="respond" data-replyto="Reply to Rowsety Moid" aria-label='Reply to Rowsety Moid'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --><li class="comment even thread-odd thread-alt depth-1" id="li-comment-4557430888798969765"><article id="comment-4557430888798969765" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn">Boris</b> </cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798969765"><time datetime="2021-12-05T10:43:35+00:00">December 5, 2021 at 10:43 am</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Great notes, books and videos, thank you:-) See this yt series from Richard Southwell:</p><p><a href="https://youtube.com/playlist?list=PLCTMeyjMKRkoS699U0OJ3ymr3r01sI08l" rel="nofollow ugc">https://youtube.com/playlist?list=PLCTMeyjMKRkoS699U0OJ3ymr3r01sI08l</a></p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798969765' data-commentid="4557430888798969765" data-postid="6337" data-belowelement="comment-4557430888798969765" data-respondelement="respond" data-replyto="Reply to Boris" aria-label='Reply to Boris'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --><ol class="children"><li class="comment byuser comment-author-petersmith bypostauthor odd alt depth-2" id="li-comment-4557430888798969771"><article id="comment-4557430888798969771" class="ast-comment"><div class= 'ast-comment-info'><div class='ast-comment-avatar-wrap'></div><!-- Remove 1px Space
 --><header class="ast-comment-meta ast-row ast-comment-author vcard capitalize"><div class="ast-comment-cite-wrap"><cite><b class="fn"><a href='https://logicmatters.net' rel='external nofollow ugc' class='url'>Peter Smith</a></b> <span class="ast-highlight-text ast-cmt-post-author"></span></cite></div><div class="ast-comment-time"><span  class="timendate"><a href="https://www.logicmatters.net/categories/#comment-4557430888798969771"><time datetime="2021-12-08T17:24:27+00:00">December 8, 2021 at 5:24 pm</time></a></span></div></header> <!-- .ast-comment-meta --></div><section class="ast-comment-content comment"><p>Thanks for this info. Apparently there is a related book too &#8230; but self-published at an absurd price (unless Amazon have got the decimal point in the wrong place).</p><div class="ast-comment-edit-reply-wrap"> <span class="ast-reply-link"><a rel='nofollow' class='comment-reply-link' href='#comment-4557430888798969771' data-commentid="4557430888798969771" data-postid="6337" data-belowelement="comment-4557430888798969771" data-respondelement="respond" data-replyto="Reply to Peter Smith" aria-label='Reply to Peter Smith'>Reply</a></span></div></section> <!-- .ast-comment-content --></article><!-- #comment-## --></li><!-- #comment-## --></ol><!-- .children --></li><!-- #comment-## --></ol><!-- .ast-comment-list --><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/categories/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.logicmatters.net/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><div class="ast-comment-formwrap ast-row"><p class="comment-form-author ast-grid-common-col ast-width-lg-33 ast-width-md-4 ast-float"><label for="author" class="screen-reader-text">Name*</label><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p><p class="comment-form-email ast-grid-common-col ast-width-lg-33 ast-width-md-4 ast-float"><label for="email" class="screen-reader-text">Email*</label><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p><p class="comment-form-url ast-grid-common-col ast-width-lg-33 ast-width-md-4 ast-float"><label for="url"><label for="url" class="screen-reader-text">Website</label><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></label></p></div><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='6337' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="acfe5184ac" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="196"/></p></form></div><!-- #respond --></div><!-- #comments --></main><!-- #main --></div><!-- #primary --></div> <!-- ast-container --></div><!-- #content --><footer
class="site-footer" id="colophon" itemtype="https://schema.org/WPFooter" itemscope="itemscope" itemid="#colophon"><div class="site-primary-footer-wrap ast-builder-grid-row-container site-footer-focus-item ast-builder-grid-row-4-rheavy ast-builder-grid-row-tablet-4-equal ast-builder-grid-row-mobile-full ast-footer-row-stack ast-footer-row-tablet-stack ast-footer-row-mobile-stack" data-section="section-primary-footer-builder"><div class="ast-builder-grid-row-container-inner"><div class="ast-builder-footer-grid-columns site-primary-footer-inner-wrap ast-builder-grid-row"><div class="site-footer-primary-section-1 site-footer-section site-footer-section-1"><aside
 class="footer-widget-area widget-area site-footer-focus-item footer-widget-area-inner" data-section="sidebar-widgets-footer-widget-1" aria-label="Footer Widget 1"				><section id="text-4" class="widget widget_text"><h2 class="widget-title">Newsletters</h2><div class="textwidget"><p><a href="https://www.logicmatters.net/subscribe-for-email-notifications-of-updates/">Subscribe here</a></p></div></section><section id="annual_archive_widget-6" class="widget Annual_Archive_Widget"><h2 class="widget-title">Blog archive</h2><ul><li><a href='https://www.logicmatters.net/2021/'>2021</a></li><li><a href='https://www.logicmatters.net/2020/'>2020</a></li><li><a href='https://www.logicmatters.net/2019/'>2019</a></li><li><a href='https://www.logicmatters.net/2018/'>2018</a></li><li><a href='https://www.logicmatters.net/2017/'>2017</a></li><li><a href='https://www.logicmatters.net/2016/'>2016</a></li><li><a href='https://www.logicmatters.net/2015/'>2015</a></li><li><a href='https://www.logicmatters.net/2014/'>2014</a></li><li><a href='https://www.logicmatters.net/2013/'>2013</a></li><li><a href='https://www.logicmatters.net/2012/'>2012</a></li><li><a href='https://www.logicmatters.net/2011/'>2011</a></li><li><a href='https://www.logicmatters.net/2010/'>2010</a></li><li><a href='https://www.logicmatters.net/2009/'>2009</a></li><li><a href='https://www.logicmatters.net/2008/'>2008</a></li><li><a href='https://www.logicmatters.net/2007/'>2007</a></li><li><a href='https://www.logicmatters.net/2006/'>2006</a></li></ul></section></aside></div><div class="site-footer-primary-section-2 site-footer-section site-footer-section-2"><aside
 class="footer-widget-area widget-area site-footer-focus-item footer-widget-area-inner" data-section="sidebar-widgets-footer-widget-2" aria-label="Footer Widget 2"		><section id="linkcat-24" class="widget widget_links"><h2 class="widget-title">Logic/Maths blogs</h2><ul class='xoxo blogroll'><li><a href="http://karagila.org/blog.html" title="A.K. is a PhD student working on set theories without choice and related matters: a very active and wonderfully informed presence on math.stackexchange and math overflow">Asaf Karagila&#039;s blog</a></li><li><a href="https://bartoszmilewski.com" title="BM mostly posts, very lucidly, on category theory">Bartosz Milewski&#039;s blog</a></li><li><a href="http://boolesrings.org/" title="Links to blogs and other sites by logic/set theory people">Boole&#039;s Rings</a></li><li><a href="http://rjlipton.wordpress.com" title="Dick Lipton and Ken Regan blog on computational complexity, and other around and about computation etc.">Gödel&#039;s Lost Letter</a></li><li><a href="http://homotopytypetheory.org/blog/" title="Homotopy Type Theory blog. Cutting edge stuff. Way outside my comfort zone but I guess we need to know what the cool kids are up to &#8230;.">HOTT blog</a></li><li><a href="http://jdh.hamkins.org" title="From the very active set-theorist JDH">Joel David Hamkins&#039;s blog</a></li><li><a href="http://m-phi.blogspot.co.uk" title="A blog dedicated to mathematical philosophy.">M-Phi</a></li><li><a href="https://prooftheory.blog/" title="Proof theory blog">Proof Theory blog</a></li><li><a href="http://qchu.wordpress.com" title="&#8220;Annoying Precision&#8221;: QY is a grad student who blogs well on a range of topics including some of general, foundational, interest">Qiaochu Yuan&#039;s blog</a></li><li><a href="http://richardzach.org" title="Richard Zach&#8217;s blog, mostly with various kinds of logic news">Richard Zach&#039;s blog</a></li><li><a href="http://www.scottaaronson.com/blog/" title="Shtetl-optimized &#8230; quantum computing etc.">Scott Aaronson&#039;s blog</a></li><li><a href="http://terrytao.wordpress.com" title="Terence Tao&#8217;s research and expository papers, discussion of open problems, and other maths-related topics.">Terence Tao&#039;s blog</a></li><li><a href="http://golem.ph.utexas.edu/category/" title="A group blog on math, physics and philosophy">The n-Category Café</a></li><li><a href="http://gowers.wordpress.com/" title="Stellar mathematician, now less active blog includes occasional posts of more general conceptual interest to philosophers of maths">Timothy Gowers&#039;s blog</a></li></ul></section></aside></div><div class="site-footer-primary-section-3 site-footer-section site-footer-section-3"><aside
 class="footer-widget-area widget-area site-footer-focus-item footer-widget-area-inner" data-section="sidebar-widgets-footer-widget-3" aria-label="Footer Widget 3"		><section id="linkcat-31" class="widget widget_links"><h2 class="widget-title">Musicians' sites</h2><ul class='xoxo blogroll'><li><a href="http://www.aam.co.uk">Acad. Ancient Music</a></li><li><a href="http://alinaibragimova.com" target="_blank">Alina Ibragimova</a></li><li><a href="http://www.angelahewitt.com">Angela Hewitt</a></li><li><a href="https://bachtrack.com/" target="_blank">Bachtrack</a></li><li><a href="https://www.belceaquartet.com">Belcea Quartet</a></li><li><a href="https://borisgiltburg.com">Boris Giltburg</a></li><li><a href="http://chiaroscuroquartet.com" target="_blank">Chiaroscuro Quartet</a></li><li><a href="https://cuartetocasals.com">Cuarteto Casals</a></li><li><a href="http://davidfraymusic.com">David Fray</a></li><li><a href="http://doricstringquartet.com">Doric String Quartet</a></li><li><a href="https://www.doverquartet.com">Dover Quartet</a></li><li><a href="http://www.elisabethbrauss.com">Elisabeth Brauß</a></li><li><a href="http://francescopiemontesi.com">Francesco Piemontesi</a></li><li><a href="http://www.imogen-cooper.com/">Imogen Cooper</a></li><li><a href="https://www.ivanagavric.com" target="_blank">Ivana Gavric</a></li><li><a href="https://www.leadesandre.com">Lea Desandre</a></li><li><a href="http://www.pavelhaasquartet.com/en" title="The most exciting string quartet playing today?" target="_blank">Pavel Haas Quartet</a></li><li><a href="http://www.rachelpodger.com">Rachel Podger</a></li><li><a href="http://www.sabinedevieilhe.com">Sabine Devieilhe</a></li></ul></section></aside></div><div class="site-footer-primary-section-4 site-footer-section site-footer-section-4"><aside
 class="footer-widget-area widget-area site-footer-focus-item footer-widget-area-inner" data-section="sidebar-widgets-footer-widget-4" aria-label="Footer Widget 4"		><section id="recent-comments-5" class="widget widget_recent_comments"><h2 class="widget-title">Recent comments</h2><nav role="navigation" aria-label="Recent comments"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Amedeo</span> on <a href="https://www.logicmatters.net/2021/12/31/the-revised-study-guide-almost-complete-version/#comment-4557430888798969828">The revised Study Guide: almost complete version</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://logicmatters.net' rel='external nofollow ugc' class='url'>Peter Smith</a></span> on <a href="https://www.logicmatters.net/2021/12/22/the-revised-study-guide-final-chapter/#comment-4557430888798969799">The revised Study Guide &#8212; final chapter</a></li><li class="recentcomments"><span class="comment-author-link">HM</span> on <a href="https://www.logicmatters.net/2021/12/22/the-revised-study-guide-final-chapter/#comment-4557430888798969798">The revised Study Guide &#8212; final chapter</a></li></ul></nav></section><section id="custom-twitter-feeds-widget-3" class="widget widget_custom-twitter-feeds-widget"><h2 class="widget-title">@PeterSmith’s tweets and retweets</h2><!-- Custom Twitter Feeds by Smash Balloon --><div id="ctf" class="ctf ctf-type-usertimeline  ctf-styles" style="width: 100%;" data-ctfshortcode="{}" data-postid="6337" data-feed-id="ctf__PeterSmith2" data-ctfneeded="-1"><div class="ctf-tweets"><div class="ctf-item ctf-author-petersmith ctf-new ctf-hide-avatar ctf-quoted" id="1476985807546327042" style=""><div class="ctf-author-box"><div class="ctf-author-box-link" style="font-size: 12px;font-weight: normal;color: #1e73be;"><a href="https://twitter.com/PeterSmith" target="_blank" rel="noopener noreferrer" class="ctf-author-name" style="font-size: 12px;font-weight: normal;color: #1e73be;">Peter Smith</a><a href="https://twitter.com/PeterSmith" class="ctf-author-screenname" target="_blank" rel="noopener noreferrer" style="font-size: 12px;font-weight: normal;color: #1e73be;">@PeterSmith</a><span class="ctf-screename-sep" style="font-size: 12px;">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/PeterSmith/status/1476985807546327042" class="ctf-tweet-date" target="_blank" rel="noopener noreferrer" style="color: #1e73be;">11h</a></div></div></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="font-size: 12px;color: #1e73be;">The Sorolla exhibition at the National Gallery a few years ago was a wonderful revelation … and this life-sized canvas was a highlight!</div><a href="https://twitter.com/artist_sorolla/status/1476980636686721026" class="ctf-quoted-tweet" style="color: #1e73be;" target="_blank" rel="noopener noreferrer"><span class="ctf-quoted-author-name">Joaquín Sorolla</span><span class="ctf-quoted-author-screenname">@artist_sorolla</span><p class="ctf-quoted-tweet-text" style="font-size: 12px;color: #1e73be;">Strolling along the Seashore, 1909 #joaquinsorolla #impressionism</p></a><div class="ctf-tweet-actions"></div></div><div class="ctf-item ctf-author-petersmith ctf-new ctf-hide-avatar" id="1476908455168548876" style=""><div class="ctf-author-box"><div class="ctf-author-box-link" style="font-size: 12px;font-weight: normal;color: #1e73be;"><a href="https://twitter.com/PeterSmith" target="_blank" rel="noopener noreferrer" class="ctf-author-name" style="font-size: 12px;font-weight: normal;color: #1e73be;">Peter Smith</a><a href="https://twitter.com/PeterSmith" class="ctf-author-screenname" target="_blank" rel="noopener noreferrer" style="font-size: 12px;font-weight: normal;color: #1e73be;">@PeterSmith</a><span class="ctf-screename-sep" style="font-size: 12px;">&middot;</span><div class="ctf-tweet-meta"><a href="https://twitter.com/PeterSmith/status/1476908455168548876" class="ctf-tweet-date" target="_blank" rel="noopener noreferrer" style="color: #1e73be;">16h</a></div></div></div><div class="ctf-tweet-content"><p class="ctf-tweet-text" style="font-size: 12px;color: #1e73be;">A bit of light holiday reading for you! I didn’t quite finish it by the end of the year, dammit, but at least there is an almost complete draft now of the Beginning Math Logic Study Guide. There’s a link, and more, at http://logicmatters.net/blog.</div><div class="ctf-tweet-actions"></div></div></div><a href="javascript:void(0);" id="ctf-more" class="ctf-more" style=""><span>Load More...</span></a></div></section></aside></div></div></div></div><div class="site-below-footer-wrap ast-builder-grid-row-container site-footer-focus-item ast-builder-grid-row-full ast-builder-grid-row-tablet-full ast-builder-grid-row-mobile-full ast-footer-row-stack ast-footer-row-tablet-stack ast-footer-row-mobile-stack" data-section="section-below-footer-builder"><div class="ast-builder-grid-row-container-inner"><div class="ast-builder-footer-grid-columns site-below-footer-inner-wrap ast-builder-grid-row"><div class="site-footer-below-section-1 site-footer-section site-footer-section-1"><div class="ast-builder-layout-element ast-flex site-footer-focus-item ast-footer-copyright" data-section="section-footer-builder"><div class="ast-footer-copyright"><p>Copyright &copy; 2022 Logic Matters | Powered by <a href="https://wpastra.com/" rel="nofollow noopener" target="_blank">Astra WordPress Theme</a></p></div></div></div></div></div></div></footer><!-- #colophon --></div><!-- #page --> <a id="ast-scroll-top" class="ast-scroll-top-icon ast-scroll-to-top-right" data-on-devices="both"> <span class="ast-icon icon-arrow"><svg class="ast-arrow-svg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="26px" height="16.043px" viewBox="57 35.171 26 16.043" enable-background="new 57 35.171 26 16.043" xml:space="preserve"> <path d="M57.5,38.193l12.5,12.5l12.5-12.5l-2.5-2.5l-10,10l-10-10L57.5,38.193z"/> </svg></span> <span class="screen-reader-text">Scroll to Top</span> </a> <script id='astra-theme-js-js-extra'> var astra = {"break_point":"770","isRtl":"","edit_post_url":"https:\/\/www.logicmatters.net\/wp-admin\/post.php?post={{id}}&action=edit","ajax_url":"https:\/\/www.logicmatters.net\/wp-admin\/admin-ajax.php","infinite_count":"2","infinite_total":"0","pagination":"number","infinite_scroll_event":"scroll","no_more_post_message":"No more posts to show.","grid_layout":"1","site_url":"https:\/\/www.logicmatters.net","show_comments":"Show Comments","masonryEnabled":"","blogMasonryBreakPoint":"770"}; </script> <script id='astra-addon-js-js-extra'> var astraAddon = {"sticky_active":"","svgIconClose":"<span class=\"ast-icon icon-close\"><svg viewBox=\"0 0 512 512\" aria-hidden=\"true\" role=\"img\" version=\"1.1\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" width=\"18px\" height=\"18px\">\n <path d=\"M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z\" \/>\n <\/svg><\/span>","header_main_stick":"0","header_above_stick":"0","header_below_stick":"0","stick_header_meta":"","header_main_stick_meta":"","header_above_stick_meta":"","header_below_stick_meta":"","sticky_header_on_devices":"desktop","sticky_header_style":"none","sticky_hide_on_scroll":"0","break_point":"770","tablet_break_point":"770","mobile_break_point":"544","header_main_shrink":"1","header_logo_width":"","responsive_header_logo_width":{"desktop":2,"tablet":"","mobile":""},"stick_origin_position":"","site_layout":"ast-full-width-layout","site_content_width":"890","site_layout_padded_width":"1200","site_layout_box_width":"1200","header_builder_active":"1","component_limit":"10","is_header_builder_active":"1"}; </script> <script id='ctf_scripts-js-extra'> var ctf = {"ajax_url":"https:\/\/www.logicmatters.net\/wp-admin\/admin-ajax.php"}; </script> <script defer src="https://www.logicmatters.net/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-js-7ebe7e0c9985c17f8d7d6ed6ed7358e1.js"></script></body></html>